Allow the formal engine to perform a same-cycle result in the ALU
[soc.git] / nix / ls180.nix
index 0c3d845e189a08681c73a31ace86ed1e5a788a8b..028fbcb0a3467041c7ab5c56e144c6b1bee09863 100644 (file)
@@ -1,6 +1,6 @@
 { version }:
 
-{ stdenv, python3Packages, yosys, libresoc-pre-litex, libresoc-pinmux }:
+{ stdenv, python3Packages, yosys, libresoc-verilog, libresoc-pinmux, pkgsCross }:
 
 stdenv.mkDerivation {
   pname = "libresoc-ls1804k";
@@ -8,9 +8,11 @@ stdenv.mkDerivation {
 
   src = ../src/soc/litex/florent;
 
-  nativeBuildInputs = with python3Packages; [
+  nativeBuildInputs =
+    (with python3Packages; [
     python libresoc-soc litex litedram liteeth liteiclink litescope litesdcard
-  ];
+    ])
+    ++ [ pkgsCross.powernv.buildPackages.gcc ];
 
   postPatch = ''
     patchShebangs --build .
@@ -22,7 +24,7 @@ stdenv.mkDerivation {
     runHook preBuild
     export PINMUX="$(mktemp -d)"
     ln -s ${libresoc-pinmux} "$PINMUX/ls180"
-    cp ${libresoc-pre-litex} libresoc/libresoc.v
+    cp ${libresoc-verilog} libresoc/libresoc.v
     ./ls180soc.py --build --platform=ls180sram4k --num-srams=2 --srams4k
     runHook postBuild
   '';