package/wayland-protocols: fix build without host-wayland
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 19 Sep 2021 09:39:01 +0000 (11:39 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 19 Sep 2021 11:24:21 +0000 (13:24 +0200)
Don't require wayland-scanner if tests are disabled to avoid the
following build failure raised since bump to version 1.23 in commit
7eedc9cc1e0c3cce1c18cb150157cb2346075b23:

Build-time dependency wayland-scanner found: NO (tried pkgconfig and cmake)

../output-1/build/wayland-protocols-1.23/meson.build:11:0: ERROR: Dependency "wayland-scanner" not found, tried pkgconfig and cmake

Fixes:
 - http://autobuild.buildroot.org/results/2744e50465a9cd9d3726d23298ad6c943ef49a21

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/wayland-protocols/0001-meson.build-wayland-scanner-is-only-needed-for-tests.patch [new file with mode: 0644]

diff --git a/package/wayland-protocols/0001-meson.build-wayland-scanner-is-only-needed-for-tests.patch b/package/wayland-protocols/0001-meson.build-wayland-scanner-is-only-needed-for-tests.patch
new file mode 100644 (file)
index 0000000..ff3ec57
--- /dev/null
@@ -0,0 +1,42 @@
+From 80e97bd00bf6263845aa98b411507baba28be67e Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 19 Sep 2021 11:01:00 +0200
+Subject: [PATCH] meson.build: wayland-scanner is only needed for tests
+
+wayland-scanner is only needed for tests so don't require it if tests
+are disabled
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Retrieved from:
+https://gitlab.freedesktop.org/wayland/wayland-protocols/-/commit/80e97bd00bf6263845aa98b411507baba28be67e]
+---
+ meson.build       | 2 --
+ tests/meson.build | 1 +
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 94b49e7..15dbc37 100644
+--- a/meson.build
++++ b/meson.build
+@@ -8,8 +8,6 @@ wayland_protocols_version = meson.project_version()
+ fs = import('fs')
+-dep_scanner = dependency('wayland-scanner', native: true)
+-
+ stable_protocols = [
+       'presentation-time',
+       'viewporter',
+diff --git a/tests/meson.build b/tests/meson.build
+index 66337e7..74824ae 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -1,4 +1,5 @@
+ prog_scan_sh = find_program('scan.sh')
++dep_scanner = dependency('wayland-scanner', native: true)
+ prog_scanner = find_program(dep_scanner.get_pkgconfig_variable('wayland_scanner'))
+ libwayland = [
+-- 
+GitLab
+