Add powerpc microwatt target
authorJoel Stanley <joel@jms.id.au>
Tue, 5 May 2020 12:31:24 +0000 (22:01 +0930)
committerJoel Stanley <joel@jms.id.au>
Thu, 23 Sep 2021 06:27:57 +0000 (15:57 +0930)
This selects the correct compiler flags so we generate instructions that
microwatt supports.

Signed-off-by: Joel Stanley <joel@jms.id.au>
arch/Config.in.powerpc
package/Makefile.in

index ba56c9c721f623c4e5d4ca575675f34cd1455f34..03687bedd1b7279c506882dee845d16093a63d27 100644 (file)
@@ -126,6 +126,8 @@ config BR2_powerpc_power7
 config BR2_powerpc_power8
        bool "power8"
        select BR2_POWERPC_CPU_HAS_ALTIVEC
+config BR2_powerpc_microwatt
+       bool "microwatt"
 endchoice
 
 choice
index 86db62ba5ba51f8f24bdc28d7480db5e812f4f9b..796011dd69da978bf89542bc918d88516e2163fa 100644 (file)
@@ -93,6 +93,9 @@ ifeq ($(BR2_powerpc_e500mc),y)
 TARGET_ABI += -mabi=spe -mfloat-gprs=double -Wa,-me500mc
 endif
 endif
+ifeq ($(BR2_powerpc_microwatt),y)
+TARGET_ABI += -mno-vsx -mno-altivec
+endif
 
 # Use longcalls option for Xtensa globally.
 # The 'longcalls' option allows calls across a greater range of addresses,