Add empty flake
[soc.git] / flake.nix
1 # The license for this file is included in the `nix` directory next to this file.
2
3 {
4 description = "FOSS CPU/GPU/VPU/SoC all in one, see https://libre-soc.org/";
5
6 inputs.nixpkgs.url = "github:L-as/nixpkgs?ref=alliance"; # for alliance
7
8 outputs = { self, nixpkgs }:
9 let
10 version = builtins.substring 0 8 self.lastModifiedDate;
11
12 supportedSystems = [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
13
14 forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
15
16 nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; overlays = [ self.overlay ]; });
17
18 in
19 {
20 overlay = final: prev: {};
21 };
22 }