Allow the formal engine to perform a same-cycle result in the ALU
[soc.git] / nix / ecp5-program.nix
1 { version }:
2
3 { writeShellScript, openocd, python3Packages, libresoc-ecp5, nextpnr, trellis }:
4
5 let
6 pythonWithEnv = python3Packages.python.withPackages (ps: with ps; [
7 requests migen libresoc-soc litex-boards litex litedram liteeth liteiclink litescope litesdcard
8 ]);
9 in
10 writeShellScript "program-ecp5-libresoc" ''
11 export PATH="${openocd}/bin:${pythonWithEnv}/bin:${trellis}/bin:${nextpnr}/bin:$PATH"
12
13 dir="$(mktemp -d)"
14 pushd "$dir"
15 echo "$dir"
16
17 export PYTHONPATH="${../src/soc/litex/florent}:$PYTHONPATH"
18
19 python ${../src/soc/litex/florent/versa_ecp5.py} --sys-clk-freq=55e6 --load-from ${libresoc-ecp5}
20
21 popd
22 rm -rf "$dir"
23 exit 0
24 ''