Allow the formal engine to perform a same-cycle result in the ALU
[soc.git] / nix / nmutil.nix
1 { lib, buildPythonPackage, bigfloat, fetchgit, pyvcd }:
2
3 buildPythonPackage {
4 pname = "libresoc-nmutil";
5 version = "unstable-2021-08-24";
6
7 propagatedBuildInputs = [ pyvcd ];
8
9 src = fetchgit {
10 url = "https://git.libre-soc.org/git/nmutil.git";
11 rev = "efda080db6978d249a23003bec734f1cc07de329";
12 sha256 = "nTgUiZc4CC0VoUND29kHSIyMlP9IB3oZfehutoNK07w=";
13 };
14
15 doCheck = false;
16
17 meta = with lib; {
18 homepage = "https://pypi.org/project/libresoc-ieee754fpu/";
19 license = licenses.lgpl3Plus;
20 };
21 }