Allow the formal engine to perform a same-cycle result in the ALU
[soc.git] / nix / verilog.nix
1 { version }:
2
3 { runCommand, python3Packages, libresoc-pinmux }:
4
5 let script = ''
6 mkdir pinmux
7 ln -s ${libresoc-pinmux} pinmux/ls180
8 export PINMUX="$(realpath ./pinmux)"
9 python3 -m soc.simple.issuer_verilog \
10 --debug=jtag --enable-core --enable-pll \
11 --enable-xics --enable-sram4x4kblock --disable-svp64 \
12 $out
13 ''; in
14 runCommand "libresoc.v" {
15 inherit version;
16
17 nativeBuildInputs = (with python3Packages; [
18 libresoc-soc
19 ]) ++ [ libresoc-pinmux ];
20 } script