MulOutputData was only 64-bit output not 128-bit
[soc.git] / nix / pinmux.nix
1 { version }:
2
3 { stdenv, python2 }:
4
5 stdenv.mkDerivation {
6 pname = "libresoc-pinmux";
7 inherit version;
8
9 src = ../pinmux;
10
11 nativeBuildInputs = [ python2 ];
12
13 configurePhase = "true";
14
15 buildPhase = ''
16 runHook preBuild
17 python src/pinmux_generator.py -v -s ls180 -o ls180
18 runHook postBuild
19 '';
20
21 installPhase = ''
22 runHook preInstall
23 mv ls180 $out
24 runHook postInstall
25 '';
26
27 fixupPhase = "true";
28 }