Fix nmigen dependencies
[soc.git] / nix / verilog.nix
index ce5167c1682afb29c0a1eeebf84f0f8d31e383cb..41b092ac4ac0d1940fc19b8bee82bd390ae8b011 100644 (file)
@@ -1,6 +1,6 @@
 { version }:
 
-{ stdenv, python3Packages, python2 }:
+{ stdenv, python3Packages, python2, yosys }:
 
 stdenv.mkDerivation {
   pname = "libresoc.v";
@@ -10,9 +10,9 @@ stdenv.mkDerivation {
 
   strictDeps = true;
 
-  nativeBuildInputs = with python3Packages; [
+  nativeBuildInputs = (with python3Packages; [
     c4m-jtag nmigen-soc python libresoc-ieee754fpu libresoc-openpower-isa
-  ];
+  ]) ++ [ yosys ];
 
   configurePhase = "true";